Android P da un paso adelante: Bloqueará las aplicaciones anteriores a Jelly Bean

Android

Uno de los problemas que tiene el ecosistema Android es la grandísima cantidad de aplicaciones que existen. Esto también es una ventaja, teniendo en cuenta que podemos elegir entre todas ellas, aunque a la larga las diferentes versiones se van quedando obsoletas y, al final, funcionan mal. Lo que no se esperaban los desarrolladores es la puesta en marcha de una nueva política ciertamente llamativa en Google Play: si se quieren publicar aplicaciones en la tienda oficial, la API deberá tener como máximo un año de antigüedad.

La nueva Developers Preview de Android P ha demostrado lo dicho: se han comenzado a bloquear las aplicaciones que tienen APIs demasiado antiguas. Concretamente, aquellas que son anteriores a la API de Android 4.2 Jelly Bean. El nuevo mínimo se establece en la versión 17. En el caso de usar una anterior a esta, las aplicaciones no se podrán ejecutar.


Hay que tener en cuenta que este un requisito de Google Play Store, además de un bloqueo establecido en Android P. La restricción, por supuesto, se seguirá aplicando a la versión final del sistema operativo, por lo que os recomendamos estar bastante atentos a las noticias que se vayan publicando.

Debemos tener en cuenta que el uso de APIs demasiado antiguas en sistemas operativos modernos podría dar lugar a problemas de seguridad y rendimiento, entre otros, por lo que Google ha llevado a cabo esta medida con el fin de evitar que haya nuevos inconvenientes en el uso del software. Y esperamos, por supuesto, que con este nuevo movimiento Android se perfeccione aún más.


Con información de Softhoy